flutter之发布过程中遇到的问题

1.ios编辑出现如下错误

这是因为Xcode10是默认选中的最新的New Build System(Default),在这个编译系统的环境下,打包的CI脚本一直会报错。

解决方案:

Xcode菜单栏选择File– Workspace Setting,把new build system(Defalt)切换到 Legacy Build System 在模拟器上运行就OK!

参考连接:

【Flutter】IOS打包

2.iOS提交时出现:Non-public API usage

需要先运行